R
    ¢¤Òj+$  ã                   óx   €   ] QH GsGsGs QQ,s\ \2        Q Q2      2       s\ \2        Q Q2      2       sP! )é    )ÚStrEnumÚIntEnumÚ_simple_enumÚ
HTTPStatusÚ
HTTPMethodc                   óˆ  ` €   \ sQ s]s n QsQ	Q ks\Q 2       s\Q 2       s\Q 2       s	\Q 2       s
\Q 2       sQ
sQsQsQsQsQsQsQsQsQsQsQsQsQsQsQsQsQsQsQsQs Qs!Q s"Q!s#Q"s$Q#s%Q$s&Q%s'Q&s(Q's)Q(s*Q)s+Q*s,Q+s-Q,s.Q-s/\/s0Q.s1\1s2Q/s3Q0s4\4s5Q1s6Q2s7Q3s8Q4s9\9s:Q5s;Q6s<Q7s=Q8s>Q9s?Q:s@Q;sAQ<sBQ=sCQ>sDQ?sEQ@sFQAsGQBsHQCsIQDsJQEsKQFsLQGsMQsNU sOP! )Hr   a	  HTTP status codes and reason phrases

Status codes from the following RFCs are all observed:

    * RFC 9110: HTTP Semantics, obsoletes 7231, which obsoleted 2616
    * RFC 6585: Additional HTTP Status Codes
    * RFC 3229: Delta encoding in HTTP
    * RFC 4918: HTTP Extensions for WebDAV, obsoletes 2518
    * RFC 5842: Binding Extensions to WebDAV
    * RFC 7238: Permanent Redirect
    * RFC 2295: Transparent Content Negotiation in HTTP
    * RFC 2774: An HTTP Extension Framework
    * RFC 7725: An HTTP Status Code to Report Legal Obstacles
    * RFC 7540: Hypertext Transfer Protocol Version 2 (HTTP/2)
    * RFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)
    * RFC 8297: An HTTP Status Code for Indicating Hints
    * RFC 8470: Using Early Data in HTTP
c                óV   €   [         O                  V2      oVm        V$m        V4m        U! ©N)ÚintÚ__new__Ú_value_ÚphraseÚdescription)ÚclsÚvaluer   r   Úobjs   &&&& Ú*/usr/local/lib/python3.15/http/__init__.pyr   ÚHTTPStatus.__new__   s$   � Ü�k‰k˜#Ó%ˆØŒØŒ
Ø%ŒØˆ
ó    c                ó0   €   ]dS t96*  9%       c    ]Ç6*  ! t ! )éd   © ©Úselfs   &r   Úis_informationalÚHTTPStatus.is_informational!   ó   � à�d×!Ô!˜cÑ!Ð!Ñ!Ð!r   c                ó0   €   ]ÈS t96*  9%       c    Q6*  ! t ! )éÈ   é+  r   r   s   &r   Ú
is_successÚHTTPStatus.is_success%   r   r   c                ó0   €   Q S t96*  9%       c    Q6*  ! t ! )é,  é�  r   r   s   &r   Úis_redirectionÚHTTPStatus.is_redirection)   r   r   c                ó0   €   Q S t96*  9%       c    Q6*  ! t ! )é�  éó  r   r   s   &r   Úis_client_errorÚHTTPStatus.is_client_error-   r   r   c                ó0   €   Q S t96*  9%       c    Q6*  ! t ! )éô  éW  r   r   s   &r   Úis_server_errorÚHTTPStatus.is_server_error1   r   r   r   )Ú )r   ÚContinuez!Request received, please continue)ée   zSwitching Protocolsz.Switching to new protocol; obey Upgrade header)éf   Ú
Processingz Server is processing the request)ég   zEarly Hintsz(Headers sent to prepare for the response)r   ÚOKz#Request fulfilled, document follows)éÉ   ÚCreatedzDocument created, URL follows)éÊ   ÚAcceptedz/Request accepted, processing continues off-line)éË   zNon-Authoritative InformationzRequest fulfilled from cache)éÌ   z
No Contentz"Request fulfilled, nothing follows)éÍ   zReset Contentz"Clear input form for further input)éÎ   zPartial ContentzPartial content follows)éÏ   zMulti-Statusz/Response contains multiple statuses in the body)éÐ   zAlready Reportedz#Operation has already been reported)éâ   zIM Usedz.Request completed using instance manipulations)r$   zMultiple Choicesz,Object has several resources -- see URI list)é-  zMoved Permanentlyú(Object moved permanently -- see URI list)é.  ÚFoundú(Object moved temporarily -- see URI list)é/  z	See Otherz'Object moved -- see Method and URL list)é0  zNot Modifiedz)Document has not changed since given time)é1  z	Use Proxyz@You must use proxy specified in Location to access this resource)é3  zTemporary RedirectrH   )é4  zPermanent RedirectrE   )r)   zBad Requestz(Bad request syntax or unsupported method)é‘  ÚUnauthorizedz*No permission -- see authorization schemes)é’  zPayment Requiredz"No payment -- see charging schemes)é“  Ú	Forbiddenz0Request forbidden -- authorization will not help)é”  z	Not FoundzNothing matches the given URI)é•  zMethod Not Allowedz-Specified method is invalid for this resource)é–  zNot Acceptablez%URI not available in preferred format)é—  zProxy Authentication Requiredz7You must authenticate with this proxy before proceeding)é˜  zRequest Timeoutz"Request timed out; try again later)é™  ÚConflictzRequest conflict)éš  ÚGonez5URI no longer exists and has been permanently removed)é›  zLength Requiredz"Client must specify Content-Length)éœ  zPrecondition Failedz Precondition in headers is false)é�  zContent Too LargezContent is too large)éž  zURI Too LongzURI is too long)éŸ  zUnsupported Media Typez!Entity body in unsupported format)é   zRange Not SatisfiablezCannot satisfy request range)é¡  zExpectation Failedz'Expect condition could not be satisfied)é¢  zI'm a Teapotz4Server refuses to brew coffee because it is a teapot)é¥  zMisdirected Requestz(Server is not able to produce a response)é¦  zUnprocessable Contentz8Server is not able to process the contained instructions)é§  ÚLockedzResource of a method is locked)é¨  zFailed Dependencyz&Dependent action of the request failed)é©  z	Too Earlyz:Server refuses to process a request that might be replayed)éª  zUpgrade Requiredz@Server refuses to perform the request using the current protocol)é¬  zPrecondition Requiredz8The origin server requires the request to be conditional)é­  zToo Many RequestszOThe user has sent too many requests in a given amount of time ("rate limiting"))é¯  zRequest Header Fields Too LargezVThe server is unwilling to process the request because its header fields are too large)éÃ  zUnavailable For Legal ReasonszOThe server is denying access to the resource as a consequence of a legal demand)r.   zInternal Server ErrorzServer got itself in trouble)éõ  zNot Implementedz&Server does not support this operation)éö  zBad Gatewayz+Invalid responses from another server/proxy)é÷  zService Unavailablez8The server cannot process the request due to a high load)éø  zGateway Timeoutz4The gateway server did not receive a timely response)éù  zHTTP Version Not SupportedzCannot fulfill request)éú  zVariant Also Negotiatesz*Server has an internal configuration error)éû  zInsufficient Storagez.Server is not able to store the representation)éü  zLoop Detectedz>Server encountered an infinite loop while processing a request)éþ  zNot Extendedz0Request does not meet the resource access policy)éÿ  zNetwork Authentication Requiredz7The client needs to authenticate to gain network access)PÚ__name__Ú
__module__Ú__qualname__Ú__firstlineno__Ú__doc__r   Úpropertyr   r!   r&   r+   r0   ÚCONTINUEÚSWITCHING_PROTOCOLSÚ
PROCESSINGÚEARLY_HINTSr8   ÚCREATEDÚACCEPTEDÚNON_AUTHORITATIVE_INFORMATIONÚ
NO_CONTENTÚRESET_CONTENTÚPARTIAL_CONTENTÚMULTI_STATUSÚALREADY_REPORTEDÚIM_USEDÚMULTIPLE_CHOICESÚMOVED_PERMANENTLYÚFOUNDÚ	SEE_OTHERÚNOT_MODIFIEDÚ	USE_PROXYÚTEMPORARY_REDIRECTÚPERMANENT_REDIRECTÚBAD_REQUESTÚUNAUTHORIZEDÚPAYMENT_REQUIREDÚ	FORBIDDENÚ	NOT_FOUNDÚMETHOD_NOT_ALLOWEDÚNOT_ACCEPTABLEÚPROXY_AUTHENTICATION_REQUIREDÚREQUEST_TIMEOUTÚCONFLICTÚGONEÚLENGTH_REQUIREDÚPRECONDITION_FAILEDÚCONTENT_TOO_LARGEÚREQUEST_ENTITY_TOO_LARGEÚURI_TOO_LONGÚREQUEST_URI_TOO_LONGÚUNSUPPORTED_MEDIA_TYPEÚRANGE_NOT_SATISFIABLEÚREQUESTED_RANGE_NOT_SATISFIABLEÚEXPECTATION_FAILEDÚIM_A_TEAPOTÚMISDIRECTED_REQUESTÚUNPROCESSABLE_CONTENTÚUNPROCESSABLE_ENTITYÚLOCKEDÚFAILED_DEPENDENCYÚ	TOO_EARLYÚUPGRADE_REQUIREDÚPRECONDITION_REQUIREDÚTOO_MANY_REQUESTSÚREQUEST_HEADER_FIELDS_TOO_LARGEÚUNAVAILABLE_FOR_LEGAL_REASONSÚINTERNAL_SERVER_ERRORÚNOT_IMPLEMENTEDÚBAD_GATEWAYÚSERVICE_UNAVAILABLEÚGATEWAY_TIMEOUTÚHTTP_VERSION_NOT_SUPPORTEDÚVARIANT_ALSO_NEGOTIATESÚINSUFFICIENT_STORAGEÚLOOP_DETECTEDÚNOT_EXTENDEDÚNETWORK_AUTHENTICATION_REQUIREDÚ__static_attributes__Ú__classdictcell__©Ú__classdict__s   @r   r   r      sT  ø‡ � ñô$ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð D€Hð>ÐàF€Jð8€Kð 
:€BØ=€Gð;€Hð%IÐ!àH€JØN€MØG€Oð;€Lð/ÐàN€Gð8Ðð4ÐàD€EØK€Ið5€LðL€Ið4Ðð4Ðð4€Kð6€Lð.Ðð<€Ið)€Ið9Ðð1€Nð%CÐ!ð.€Oà2€HðA€Dð.€Oð,Ðð Ðà0Ðð€Là'Ðð-Ðð(Ðà&;Ð#ð3Ðð@€Kð4ÐðDÐà0ÐØ<€Fð2ÐðF€IðLÐðDÐð4Ðð' Ð#ð%7Ð!ð(Ðð2€Oð7€KðDÐð@€Oð""Ðð6Ðð:ÐðJ€Mð<€Lð'CÖ#r   c                   óV   ` €   \ sQ s]»s n QsQ sQ sQsQsQs	Qs
Q	sQ
sQsQsQsQsU sP! )r   z½HTTP methods and descriptions

Methods from the following RFCs are all observed:

    * RFC 9110: HTTP Semantics, obsoletes 7231, which obsoleted 2616
    * RFC 5789: PATCH Method for HTTP
c                óJ   €   [         O                  V2      oVm        V#m        U! r
   )Ústrr   r   r   )r   r   r   r   s   &&& r   r   ÚHTTPMethod.__new__Ä   s   � Ü�k‰k˜#Ó%ˆØŒØ%ŒØˆ
r   c                óV   €   Q U O                   O                  8 QU O                  8 Q0! )Ú<Ú.Ú>)Ú	__class__ry   Ú_name_r   s   &r   Ú__repr__ÚHTTPMethod.__repr__Ê   s   ‚ Ø ŸN™N×3Ô3°T·[´[ÐAÐAr   r   )ÚCONNECTz%Establish a connection to the server.)ÚDELETEzRemove the target.)ÚGETzRetrieve the target.)ÚHEADzBSame as GET, but only retrieve the status line and header section.)ÚOPTIONSz2Describe the communication options for the target.)ÚPATCHz(Apply partial modifications to a target.)ÚPOSTz<Perform target-specific processing with the request payload.)ÚPUTz,Replace the target with the request payload.)ÚTRACEz>Perform a message loop-back test along the path to the target.)ry   rz   r{   r|   r}   r   rÎ   rÐ   rÑ   rÒ   rÓ   rÔ   rÕ   rÖ   r×   rØ   rÀ   rÁ   rÂ   s   @r   r   r   »   sE   ø‡ � ñòòBð A€GØ+€FØ
'€CØW€DØM€GØ?€EØQ€DØ
?€CØU†Er   )Úenumr   r   r   Ú__all__r   r   r   r   r   Ú<module>rÛ      s[   ñß /Ñ /à˜Ð
&€ñ ˆgÓ÷qCð qCó ðqCñh ˆgÓ÷Vð Vó òVr   